在宝塔里面我们经常会安装多个PHP的版本用于配置不同的 WEB 网站系统。

这时候我们就需要一个固定的PHP版本用于执行PHP脚本,就是我们说的 CLI 程序.

有两种方法修改宝塔 BT 面板中默认的PHP CLI 版本:

一、命令行方式
删除以前的

rm -f /usr/bin/php

引用你想要的版本

ln -sf /www/server/php/72/bin/php /usr/bin/php

二、面板操作方式

左侧菜单-站点管理-点击设置默认PHP CLI版本按钮

如图片所示,修改后保存就可以了。

教程-修改宝塔 BT 面板中默认的PHP CLI 版本的两种方式